Go Back   Maxima Forums > Maxima Discussions > 6th Generation Maxima (2004-2008)
Sign in using an external account
Register Forgot Password?
Search

6th Generation Maxima (2004-2008) Discussion of the 6th generation Maxima. Come see what others are saying.

Welcome to Maxima.org!
Welcome to Maxima.org,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join Maxima.org today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 03-29-2010, 07:38 AM   #1

 
Join Date: Nov 2006
iTrader: (0)
Posts: 10
Points: 5,902, Level: 49
Points: 5,902, Level: 49 Points: 5,902, Level: 49 Points: 5,902, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Check engine light on

05 max with 72xxx miles and the check engine light just came on. Went to autozone and the troubleshooting code is P0420. They said it could be large vacuum leak, fuel system fault, ignition system fault or fail bank 1 catalytic converter. Don't know what to think but the car seem to be running fine.
Freshness is offline   Reply With Quote
Old 03-29-2010, 09:34 AM   #2
Senior Member

 
Join Date: Feb 2007
Location: Chicago suburbs
iTrader: (5)
Posts: 1,578
Points: 5,424, Level: 47
Points: 5,424, Level: 47 Points: 5,424, Level: 47 Points: 5,424, Level: 47
Activity: 1.0%
Activity: 1.0% Activity: 1.0% Activity: 1.0%
If it's your bank 1 cat, you better get that taken care of fast. Cats are warrantied 8yr/80,000 miles. The dealer is obligated to repair it by law if that is indeed the problem.

Take it in ASAP.
Oolatec is offline   Reply With Quote
Old 03-29-2010, 09:35 AM   #3
Senior Member


 
Join Date: Apr 2009
Location: CA
iTrader: (0)
Posts: 569
Points: 4,536, Level: 42
Points: 4,536, Level: 42 Points: 4,536, Level: 42 Points: 4,536, Level: 42
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
one of my buddies had a similar issue with his 04, ended up spending cash on the "issue" when the cat should have been under warranty as Oolatec stated. After about 2-3 months the code popped back up again and now the dealership he went to is trying to charge him $$$$ once again...

just be careful where you go and who you trust bro....
__________________
lots of mods and more to come!

the macedonian is offline   Reply With Quote
Old 03-29-2010, 02:57 PM   #4

 
Join Date: Nov 2006
iTrader: (0)
Posts: 10
Points: 5,902, Level: 49
Points: 5,902, Level: 49 Points: 5,902, Level: 49 Points: 5,902, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Jumped back in the car and now the light is off. Could the system have corrected it's self and should i still take it in to get looked at.
Freshness is offline   Reply With Quote
Old 03-29-2010, 02:58 PM   #5
Senior Member

 
Join Date: Feb 2007
Location: Chicago suburbs
iTrader: (5)
Posts: 1,578
Points: 5,424, Level: 47
Points: 5,424, Level: 47 Points: 5,424, Level: 47 Points: 5,424, Level: 47
Activity: 1.0%
Activity: 1.0% Activity: 1.0% Activity: 1.0%
Drive around a bit... next time the light comes on, head straight to the dealer if you can. Your cats may be going bad.
__________________
Oolatec is offline   Reply With Quote
Old 03-29-2010, 04:19 PM   #6
Supporting Maxima.org Member

 
Apollos2's Avatar
 
Join Date: Nov 2004
Location: Denver, Colorado
iTrader: (16)
Posts: 2,755
Points: 11,791, Level: 71
Points: 11,791, Level: 71 Points: 11,791, Level: 71 Points: 11,791, Level: 71
Activity: 2.2%
Activity: 2.2% Activity: 2.2% Activity: 2.2%

Send a message via AIM to Apollos2
^^^^^^ +1
__________________
Cardomain = Silver stream




Nismo Wheels/ AT grounding kit / *Tein* Springs / RSB / Fujita CAI / Cattman Headers & Y pipe / Nismo Catback / ID roof spoiler/ NWP Spacers/ Timing advanced 2 degrees / UR UD pulley / Apexi SAFCII / DS Rotors / SS Brake lines / Eclipse - MTX - 8in Free air subs/
Apollos2 is offline   Reply With Quote
Old 03-29-2010, 04:47 PM   #7
Senior Member

 
Join Date: Apr 2008
Location: Salt Lake City, UT
iTrader: (1)
Posts: 1,062
Points: 5,026, Level: 45
Points: 5,026, Level: 45 Points: 5,026, Level: 45 Points: 5,026, Level: 45
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Even with the light off the code is still in the system unless you had whoever checked it clear it. I say take it to the dealer at your soonest convenience
__________________
00' SE 5 Speed/ Cattman Muffler/ Warpspeed Y/ 17 advance/ 5% tint all around/ 6000K HID's all around/ Hawk HPS's all around/ FSTB/ Alpine HU/ Alpine Type R speakers

Feldman is offline   Reply With Quote
Old 03-29-2010, 06:41 PM   #8
Member

 
Join Date: Dec 2008
Location: Memphis,tn
iTrader: (0)
Posts: 220
Points: 4,918, Level: 44
Points: 4,918, Level: 44 Points: 4,918, Level: 44 Points: 4,918, Level: 44
Activity: 2.7%
Activity: 2.7% Activity: 2.7% Activity: 2.7%
Will mine came on today n don't know what cel is on for. This is my 2nd motor n cel came on after I put 11,000 miles on it. What should it be in 11,000 miles? Cause I bought this motor new n I did oil change 3 week ago n put new k&n cone filter on my aem cai last week ago. Any clue? Can I floor the gas all the way if cel is on? I got 11,000 miles on it.
rohanmax14 is offline   Reply With Quote
Old 04-04-2010, 02:15 PM   #9
Newbie - Just Registered
 
Join Date: Feb 2010
iTrader: (0)
Posts: 2
Hey i have a question: are there two types of signs? Check engine and "Service Engine Soon"?? Or do they both mean the same thing? Because my service engine soon light just went on. I was just wondering because I thought Service Engine Soon was a dealer manufactured sign that meant to just get it serviced by the dealership, and then they can take the code off, thanks for your reply guys!
bains402 is offline   Reply With Quote
Old 04-28-2010, 08:08 AM   #10
Junior Member
 
Join Date: Apr 2010
iTrader: (1)
Posts: 19
PO420

This code came up about a month ago, and vanished after a couple of days... Now it's back, if my bank 1 cat IS going bad I definitely don't want to shell out $1200 bucks at the dealer to fix it. So what are my alternatives (CHEAP alternatives)?

- Can I have the cat gutted and install an O2 sim?
- replace the bank 1 cat with an aftermarket with a high flow (metal core)?

- Headers? Wasn't really planning on going this route

thanks!
CelticPhrost is offline   Reply With Quote
Old 04-28-2010, 09:39 AM   #11
Senior Member

 
Join Date: Feb 2007
Location: Chicago suburbs
iTrader: (5)
Posts: 1,578
Points: 5,424, Level: 47
Points: 5,424, Level: 47 Points: 5,424, Level: 47 Points: 5,424, Level: 47
Activity: 1.0%
Activity: 1.0% Activity: 1.0% Activity: 1.0%
Quote:
Originally Posted by CelticPhrost View Post
This code came up about a month ago, and vanished after a couple of days... Now it's back, if my bank 1 cat IS going bad I definitely don't want to shell out $1200 bucks at the dealer to fix it. So what are my alternatives (CHEAP alternatives)?

- Can I have the cat gutted and install an O2 sim?
- replace the bank 1 cat with an aftermarket with a high flow (metal core)?

- Headers? Wasn't really planning on going this route

thanks!
You cannot sim the primary air/fuel sensors. What year is your car? How many miles? Cats are warrantied (Federal Government law) for 8 years/80,000 miles.

If you're past your warranty, you can either gut both primary cats (they will both go bad eventually... it's a known issue Nissan refuses to acknowledge), or find someone (me!!! hehe) that has primary cats from their cars still in good condition for sale.
__________________
Oolatec is offline   Reply With Quote
Old 04-28-2010, 10:07 AM   #12
Junior Member
 
Join Date: Apr 2010
iTrader: (1)
Posts: 19
I just sent you a PM... unfortunately i'm out of warranty, 2006 but with 100,000 miles on it..
CelticPhrost is offline   Reply With Quote
Old 04-28-2010, 12:35 PM   #13
Senior Member

 
Join Date: Feb 2007
Location: Chicago suburbs
iTrader: (5)
Posts: 1,578
Points: 5,424, Level: 47
Points: 5,424, Level: 47 Points: 5,424, Level: 47 Points: 5,424, Level: 47
Activity: 1.0%
Activity: 1.0% Activity: 1.0% Activity: 1.0%
Ah... ok I got it and replied... nevermind my ? about warranty. lol

To Freshness... you are still under federal emissions warranty. The dealer is required by law to fix/replace your cats if they go bad within 8 years/80,000 miles.
__________________
Oolatec is offline   Reply With Quote
Old 05-01-2010, 07:38 PM   #14

 
Join Date: Nov 2006
iTrader: (0)
Posts: 10
Points: 5,902, Level: 49
Points: 5,902, Level: 49 Points: 5,902, Level: 49 Points: 5,902, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Autozone checked it but never cleared it. On my way home it went off and has not come back on. I don't know if i should still be concerned about it when the car is driving fine.
Freshness is offline   Reply With Quote
Old 05-02-2010, 09:41 AM   #15
Senior Member

 
Join Date: Apr 2009
Location: Philly, PA
iTrader: (4)
Posts: 477
Points: 3,217, Level: 35
Points: 3,217, Level: 35 Points: 3,217, Level: 35 Points: 3,217, Level: 35
Activity: 0.8%
Activity: 0.8% Activity: 0.8% Activity: 0.8%
Yes you should be concerned. Like ool said don't wait. Do it now while its still under warranty.
__________________

6SpeedTurbo
04CleanMaxx is offline   Reply With Quote
Old 05-04-2010, 08:10 AM   #16
Newbie - Just Registered
 
Join Date: Oct 2008
Location: Central NJ
iTrader: (0)
Posts: 2
It could be as simple as bad gas (water). Mine did the same a year ago, never came back on. Run premium fuel & some type of fuel injector cleaner once in awhile. I have 174,000 miles on my 04 Max.
Richard.Bank@Kronosww.com is offline   Reply With Quote
Old 05-22-2010, 07:47 AM   #17
Member
 
Join Date: Jan 2009
iTrader: (0)
Posts: 82
code's

Quote:
Originally Posted by Freshness View Post
05 max with 72xxx miles and the check engine light just came on. Went to autozone and the troubleshooting code is P0420. They said it could be large vacuum leak, fuel system fault, ignition system fault or fail bank 1 catalytic converter. Don't know what to think but the car seem to be running fine.

i got the same code on my o3 max,i had one of those ebay barrel's on the car with the silencer off, after getting the code i put the silencer back on and instantly the light went off and never returned.
I think it had something to do with the restriction of the exhaust system i think these engines perform's better with more restrictions than less, the ebay barrel i had was a free flow one .
A couple week's ago i replaced it with a 60 series flowmaster & i got back my quietness and performance.
I was also told that this code comes up if & when you fill up you gas tank while your motor is running.

Hey guy's go gentle on me this is my first post and i could have been wrong about the restriction issue .
bob-lee is offline   Reply With Quote
Old 05-23-2010, 12:04 PM   #18
Junior Member

 
Join Date: Oct 2008
iTrader: (0)
Posts: 25
Points: 3,927, Level: 39
Points: 3,927, Level: 39 Points: 3,927, Level: 39 Points: 3,927, Level: 39
Activity: 1.4%
Activity: 1.4% Activity: 1.4% Activity: 1.4%
whats going on everyone , I got a Quick Q about the service engine soon It came on the other day , day after it came one I drove to work after work went to autozone she ran it and said the 6 cylinder is missfiring which was a little wierd to me since I didn't feel anykind of diffrence than before , as soon she was done I got in and turn the car on and the service engine light was off. ??? Should I be worried?? Thanx
SilverBeast is offline   Reply With Quote
Old 06-06-2010, 12:01 PM   #19

 
Join Date: Nov 2006
iTrader: (0)
Posts: 10
Points: 5,902, Level: 49
Points: 5,902, Level: 49 Points: 5,902, Level: 49 Points: 5,902, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Finally made to the dealership and it is the bank 1 catalytic converter all covered under warranty. They say it's ok to drive and the part will be here in a few days.
Freshness is offline   Reply With Quote
Old 06-06-2010, 07:01 PM   #20
Newbie - Just Registered

 
Join Date: Dec 2009
iTrader: (0)
Posts: 10
Points: 2,761, Level: 32
Points: 2,761, Level: 32 Points: 2,761, Level: 32 Points: 2,761, Level: 32
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Hello people. I've got the same issue. Service engine soon light came on. I also took it over to Autozone......actually 3 different Autozones.....lol Had to make sure all opinions were close.

At first, 3-4 weeks ago, they classified it as a small vapor leak. I didn't get the code though at that point. So I thought it could of been my gas cap. Original cap still on so I bought a new factory nissan cap. Cleared out the light and now just a week ago, the light is back on. I've had the new cap on for about 2 weeks or so.

I go back to Autozone again and they classify it as a large vapor leak. The guy told me it could be a vacuum line or fuel tank issue. I have no idea.

Could it be the cat issue that a previous poster had? Need some advice here. Thanks for any help.
PLAYNU2 is offline   Reply With Quote
Old 06-10-2010, 12:14 PM   #21
Newbie - Just Registered

 
Join Date: Dec 2009
iTrader: (0)
Posts: 10
Points: 2,761, Level: 32
Points: 2,761, Level: 32 Points: 2,761, Level: 32 Points: 2,761, Level: 32
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Just got the car back from the shop for my service engine soon light. After performing diagnostics tests on it, they found it to be the vent control valve. After parts and labor, I still managed to stay under $200 and now my engine light worries are over. At least for now....
PLAYNU2 is offline   Reply With Quote
Old 06-12-2010, 09:04 AM   #22
Junior Member
 
Join Date: Dec 2009
iTrader: (0)
Posts: 25
my car had that code when I bought it.. They replaced the cat and I paid around 750 dollars..
yoshiki2 is offline   Reply With Quote
Old 07-12-2010, 09:05 AM   #23
Junior Member
 
Join Date: Jul 2010
iTrader: (0)
Posts: 25
problem

sounds like a problem that nissan should maybe look into...mine has 71k and i'm glad that you guys mentioned the 80k warranty, that will bring me some peace of mind, at least for 9k more miles ha ha
dash10299 is offline   Reply With Quote
Old 07-12-2010, 09:05 AM
MaximaOrg
Nissan Maxima




Paid Advertisement
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


 




All times are GMT -7. The time now is 02:15 PM.


Maxima.org Forums Home Here you can view your subscribed threads, work with private messages and edit your profile and preferences Frequently Asked Questions on the Forums Search Find other members Registration is free! Support Maxima.org! Receive perks and benefits by donating to Maxima.org Questions? Comments?  Suggestions? Contact Us! Visit our Sponsors View and submit Maxima events Log Out of Maxima.org
Emails Backup