SES light on---Inspection due! How to Reset? - Maxima Forums

Go Back   Maxima Forums > Maxima Discussions > 6th Generation Maxima (2004-2008)
Search


6th Generation Maxima (2004-2008) Discussion of the 6th generation Maxima. Come see what others are saying.

SES light on---Inspection due! How to Reset?

Reply
 
 
 
Thread Tools Search this Thread
Old 01-24-2011, 12:53 PM   #1
Junior Member
 
Join Date: Nov 2004
Posts: 41
SES light on---Inspection due! How to Reset?

Hey Guys,

I have a 2005 Nissan Maxima with 92000 miles on it. Recently, it started showing the "Service Engine Soon" light and I kind of ignored it. So today, I realized that my inspection is due and try to take care of this light before going in for inspection. I went to autozone and the guy told me it was the catalytic converter code P0420 and he refused to reset it. He stated that this is emissions tampering.

Is there anyway to reset this light so I can get my car inspected. I live in NJ and honestly don't want to pay the $1000-$1200 to get this fixed. I am looking to trade this in for a 2011 Maxima this summer.

I look forward to your response..

Thanks
02bluemax is offline   Reply With Quote
Old 01-24-2011, 03:11 PM   #2
Senior Member
iTrader: ( 1 )
 
Join Date: Oct 2010
Location: Cincinnati
Posts: 358
derp

http://maxima.theowensfamily.com/ecu.asp
__________________
puttin' the laughter back in slaughter
shdwonthsun is offline   Reply With Quote
Old 01-24-2011, 03:31 PM   #3
Senior Member
 
Join Date: Nov 2004
Location: Bay Shore, NY
Posts: 772
Send a message via ICQ to NIKV69 Send a message via AIM to NIKV69 Send a message via Yahoo to NIKV69
May be smart to get scanner and find out what is amiss?
__________________
"Live free or Die"
NIKV69 is online now   Reply With Quote
Old 01-24-2011, 05:03 PM   #4
Senior Member
iTrader: ( 5 )
 
Join Date: Feb 2007
Location: Chicago suburbs
Posts: 1,578
Your cats are going bad. Resetting won't help you pass. You need new cats. You're out of emissions warranty too. Your best bet at this point is to get some Racingline high flow cats.
__________________
Oolatec is offline   Reply With Quote
Old 01-24-2011, 05:26 PM   #5
Junior Member
 
Join Date: Nov 2004
Posts: 41
Quote:
Originally Posted by shdwonthsun View Post
Thank you!!! I will try it, and report back with my results.
02bluemax is offline   Reply With Quote
Old 01-24-2011, 05:28 PM   #6
Junior Member
 
Join Date: Nov 2004
Posts: 41
Quote:
Originally Posted by Oolatec View Post
Your cats are going bad. Resetting won't help you pass. You need new cats. You're out of emissions warranty too. Your best bet at this point is to get some Racingline high flow cats.
I don't really want to spend any more money on this car. I am looking to upgrade it this summer. I thought many of these codes were due to faulty ECM sensors and that there was actually nothing wrong with the cats. I am hoping that this is the case and I am able to pass the inspection this month.

Thanks
02bluemax is offline   Reply With Quote
Old 01-25-2011, 08:54 AM   #7
Senior Member
iTrader: ( 5 )
 
Join Date: Feb 2007
Location: Chicago suburbs
Posts: 1,578
The cats are known to go bad on this car. If you're tripping that code, I doubt there will be any type of fix other than replacing the cats, unfortunately.

Simply resetting the code won't be enough. When you go in for inspection, they will read your ECU, and it will basically tell them that it was reset and that it's not "ready". You have to drive at least 100 miles after a reset. My bet is that the CEL will come back.

Good luck though!
__________________

Last edited by Oolatec; 01-25-2011 at 08:58 AM.
Oolatec is offline   Reply With Quote
Old 01-25-2011, 09:49 AM   #8
Junior Member
 
Join Date: Nov 2004
Posts: 41
So I was able to reset the SES light with this method. I am going to wait a week or so and then take it in for inspection. I will post back whether I pass or not afterwards. So far the light has not reappeared. Thanks for the help.
02bluemax is offline   Reply With Quote
Old 01-25-2011, 12:17 PM   #9
Junior Member
 
Join Date: Nov 2004
Posts: 41
Quote:
Originally Posted by Oolatec View Post
The cats are known to go bad on this car. If you're tripping that code, I doubt there will be any type of fix other than replacing the cats, unfortunately.

Simply resetting the code won't be enough. When you go in for inspection, they will read your ECU, and it will basically tell them that it was reset and that it's not "ready". You have to drive at least 100 miles after a reset. My bet is that the CEL will come back.

Good luck though!
Sure enough. The light is back on, you were right. I guess I have to get it fixed.

Thanks for all the help.
02bluemax is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
NJ Corroded positve battery lead / grounding issues pktaske 6th Generation Classifieds (2004-2008) 1 05-06-2016 07:49 AM
Bent wheel, repair or replace? dcam0326 General Maxima Discussion 4 09-08-2015 11:02 PM
Passenger headlight goes out after a a few moments. Maxima30 5th Generation Maxima (2000-2003) 2 09-07-2015 06:13 PM
Tranny safe mode / Grounding issue / cable replacement pktaske 6th Generation Maxima (2004-2008) 0 09-04-2015 08:40 AM
long crank no speedo no rpm mvm062 Infiniti I30/I35 0 09-02-2015 07:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. The time now is 03:03 PM.


Maxima.org Forums Home Here you can view your subscribed threads, work with private messages and edit your profile and preferences Frequently Asked Questions on the Forums Search Find other members Registration is free! Support Maxima.org! Receive perks and benefits by donating to Maxima.org Questions? Comments?  Suggestions? Contact Us! Visit our Sponsors View and submit Maxima events Log Out of Maxima.org