Go Back   Maxima Forums > Maxima Discussions > 4th Generation Maxima (1995-1999)
Sign in using an external account
Register Forgot Password?
Search

4th Generation Maxima (1995-1999) Visit the 4th Generation forum to ask specific questions or find out more about the 4th Generation Maxima.

Welcome to Maxima.org!
Welcome to Maxima.org,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join Maxima.org today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 12-05-2012, 07:49 PM   #1
Senior Member


 
Join Date: Oct 2009
iTrader: (0)
Posts: 1,412
Points: 10,359, Level: 67
Points: 10,359, Level: 67 Points: 10,359, Level: 67 Points: 10,359, Level: 67
Activity: 1.1%
Activity: 1.1% Activity: 1.1% Activity: 1.1%
Bad EGR Temp Sensor symptoms?

got a code for it i googled it earlier everyone said it was temp sensor but now im home and cant find where i wrote the code down at lol...but what are the symptoms of a bad egr temp sensor?


i had my entire top of engine apart and cleaned 5 months ago entire EGR system cleaned to perfection and two weeks ago i sea foamed engine twice cleaned EVERYTHING out and two days later started miss firing and rough idles and on every cold start it sounds like a damn big cammed v8 just cammin away and shaking a little u hit the gas and its QUICK to rev up then drops down to idle sounding like it wants to die but it dont...it runs RICH on cold starts also.


its 99 auto with 260k miles well maintained
__________________
TravisCadello is offline   Reply With Quote
Old 12-06-2012, 06:49 AM   #2
Member who somehow became The President of The SE-L Club

 
Join Date: Jun 2001
iTrader: (19)
Posts: 15,821
Points: 36,005, Level: 100
Points: 36,005, Level: 100 Points: 36,005, Level: 100 Points: 36,005, Level: 100
Activity: 30.7%
Activity: 30.7% Activity: 30.7% Activity: 30.7%
Send a message via AIM to njmaxseltd
I don't think the egr temp sensor has anything to do with your issue.
If the code keeps coming back, replace it.
__________________

As the 4th gen ages, its owners get younger.
njmaxseltd is offline   Reply With Quote
Old 12-06-2012, 01:42 PM   #3
Member

 
Join Date: Nov 2002
Location: Hyde Park, NY
iTrader: (0)
Posts: 201
Points: 9,673, Level: 66
Points: 9,673, Level: 66 Points: 9,673, Level: 66 Points: 9,673, Level: 66
Activity: 2.4%
Activity: 2.4% Activity: 2.4% Activity: 2.4%
Vacuum leak? Or fouled plugs?
slfalco is offline   Reply With Quote
Old 12-06-2012, 05:40 PM   #4
Senior Member


 
Join Date: Oct 2009
iTrader: (0)
Posts: 1,412
Points: 10,359, Level: 67
Points: 10,359, Level: 67 Points: 10,359, Level: 67 Points: 10,359, Level: 67
Activity: 1.1%
Activity: 1.1% Activity: 1.1% Activity: 1.1%
code has been popping up few weeks now even after i clear it....what does the EGR temp sensor do?
__________________
TravisCadello is offline   Reply With Quote
Old 12-06-2012, 05:46 PM   #5
Junior Member

 
Join Date: Mar 2012
iTrader: (0)
Posts: 30
Points: 1,581, Level: 22
Points: 1,581, Level: 22 Points: 1,581, Level: 22 Points: 1,581, Level: 22
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Sounds like an injector going bad. I had problems with idle and changed/cleaned everything but it was one of the front three injectors that was bad. Literally a 5min fix to swap the front three injectors. The back three require removal of the UIM. The EGR shouldn't make the car run bad if I'm not mistaken. You'll just burn more fuel.
__________________
98 Maxima auto
225k
Custom black metallic 2-stage paint
Millani 18" chrome wheels
Infiniti leather seats/wood trim/steering wheel
Polk audio components, 12" Polk sub, 7" Navigation/DVD
BC racing coilovers
Magnaflow exhaust
RushNatU is offline   Reply With Quote
Old 12-07-2012, 08:35 AM   #6
Member

 
Join Date: Jan 2009
iTrader: (0)
Posts: 263
Points: 5,900, Level: 49
Points: 5,900, Level: 49 Points: 5,900, Level: 49 Points: 5,900, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Quote:
Originally Posted by TravisCadello View Post
code has been popping up few weeks now even after i clear it....what does the EGR temp sensor do?
It's used by the ECM to monitor the function of the EGR system. When the EGR valve opens and exhaust gas flows past the temperature sensor, it signals the ECM that the EGR valve is working. The sensor itself has no effect on driveability, it's used by the ECM for diagnosis only. If the sensor fails it won't cause the EGR valve to open at the wrong time or anything like that.
ATTappman is offline   Reply With Quote
Old 12-08-2012, 01:15 PM   #7
Senior Member


 
Join Date: Oct 2009
iTrader: (0)
Posts: 1,412
Points: 10,359, Level: 67
Points: 10,359, Level: 67 Points: 10,359, Level: 67 Points: 10,359, Level: 67
Activity: 1.1%
Activity: 1.1% Activity: 1.1% Activity: 1.1%
so dont even worry about the EGR temp sensor? it could be a injector problem but doubt it cause i run injector cleaner and only 93 octane shell v power fuel. i just put new fuel filter in too...in morning when it sounds like its a camming v8 i hit gas and she revs right up smoothly its when it idle back down its runs really rough and smells like gas strong then on its own it revs up to 1400rpm and then drops back down to idle and runs smooth the rest of the day other then random small miss fires that EVERY MAXIMA has shes runs perfect!
__________________
TravisCadello is offline   Reply With Quote
Old 12-08-2012, 01:15 PM
MaximaOrg
Nissan Maxima




Paid Advertisement
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


 




All times are GMT -7. The time now is 09:46 PM.


Maxima.org Forums Home Here you can view your subscribed threads, work with private messages and edit your profile and preferences Frequently Asked Questions on the Forums Search Find other members Registration is free! Support Maxima.org! Receive perks and benefits by donating to Maxima.org Questions? Comments?  Suggestions? Contact Us! Visit our Sponsors View and submit Maxima events Log Out of Maxima.org
Emails Backup