Bad experiences with Racingline performance - Maxima Forums



Dealership and Vendor Experiences Let other Maxima owners, or potential Maxima owners, which dealerships and shops you've had good or bad luck with.

Bad experiences with Racingline performance

Reply
 
 
 
Thread Tools Search this Thread
Old 03-09-2011, 12:01 PM   #1  
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: Houston,TX
Posts: 638
Bad experiences with Racingline performance

well in the past i've done alot of buisness with Racing ... Bought pretty much every thing they made for my car

about a few months ago i bought the Racingline New high flow pre-cats ... was actually one of the first cars to get em

i got the first batch price of $480 dollars

i drove the car MAYBE 10k miles ... i don't daily this car its more of a weekend car for me i have another daily

so recently i got a CEL ... from the O2 ..... and then later that week i have bought a rebuilt tranny that i was putting in so i decided to tell me mech take my cats of see what gives

3/4 of the Honey Comb was gone ...(which is ceramic)

not even 10k miles on the car and they are already gone


so i tried contacting them and i got no replies from the maxima.org racingline user name ... i sent 5-6 pms

then i emailed them and got a call 3-4 days later we talked and he said its something related to my car

and didn't wanna claim upto the warranty .. instead asked me for $390 for 2 new pair

these cats were a Waste of my money and i should've got the cattman headers ...






NOW second i just bought some aluminum motor mounts from them and this is what i got

http://www.youtube.com/watch?v=m9ZGTeF1yx8

now trying to contact them .. called them atleast 40 times .. they don't really like answering the phone

sent them emails and after a few days got a reply saying im confused on how this could happen from them

after spending more then 1k with these guys i feel dissapointed they treat their customers like this ...

The most horrid customer service i've ever gotten from any kind of buisness
taz394 is offline   Reply With Quote
Old 03-09-2011, 12:04 PM   #2  
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: Houston,TX
Posts: 638
i ended up gutting my cats and they ended up costing ALOT more then cattman headers

There is no such thing as a warranty as they claim on their website

it took him 3 weeks to ship my mounts after payment when they were suppose to ship out within a few days and even after waiting 3 weeks i got these mounts that are WAYY to small...more downtime on my car ... more money out of my pocket for car being in shop with subframe off .. now im paying a shop to make me some rings and get them to fit ... cause i know contacting racingline is a waste !
taz394 is offline   Reply With Quote
Old 03-09-2011, 12:20 PM   #3  
Senior Member
iTrader: (22)
 
Join Date: Oct 2007
Location: New Orleans,La.
Posts: 1,397
Sorry to hear that you guys had to go through this aweful service thanks for posting up and forewarning us
mista0406 is offline   Reply With Quote
Old 03-09-2011, 12:32 PM   #4  
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: Houston,TX
Posts: 638
i wouldn't even have posted this if the issue was resolved ... probably would've left them another good feedback for still mannng upto the warranty

but nope .. they didn't want to

and the worst part that makes me mad is the part that they DO NOT answer the phone

its impossible to contact them
taz394 is offline   Reply With Quote
Old 03-10-2011, 05:45 AM   #5  
Member
iTrader: (2)
 
Join Date: Oct 2010
Location: RI
Posts: 37
WOW.....Can't believe that...i feel i wasted money on the pre cats and y pipe....wish i bought headers instead...i only have about 500 miles on my pre cats...i hope it doesnt end up like that...i also got the front motor mount insert from them....i can't believe your mounts though. wish you best of luck man.
08MaximaSE is offline   Reply With Quote
Old 03-10-2011, 10:56 AM   #6  
TAZ
Supporting Maxima.org Member
iTrader: (20)
 
Join Date: Oct 2004
Location: vancouver, BC
Posts: 589
as a rebuttal,

yes there were some delays for which I will make no excuse but at no time did we not offer to work with you. You were asked to return the cats for inspection because we felt that the amount of soot on such a new part was abnormal and likely that your car is burning something. Either oil, fuel or both. It is not normal for a core to unwind like that unless there is an extreme amount of heat build up like unburnt fuel. And no they are not ceramic.

Based on previous pics you posted here your oem precats were crumbling into dust, which often leads to scored cylinder walls and oil burning issues. Coupled with your spraying of N2o and your admission you've bought a new motor as well, we wanted to inspect the cats. In one of your emails you even offered to buy a new set if we could cut you a break. I sent you deeply discounted paypal requests for front and rear cats individually as you never did confirm the condition of your rear cat and told you that pending inspection the charge may be refunded (basicly a core exchange). our last correspondence on the matter was that you chose to go a different route......

As for the mounts, I again told you to get me pics of the issue so I could see the exact issue and could then offer a remedy, you said you would get them to me the following day and you never did. My first visual reference to the mount issue is this thread. I can still make a corrected set for you or refund you if you wish now that I can see that something is definitely wrong.
TAZ is offline   Reply With Quote
Old 03-10-2011, 11:05 AM   #7  
Senior Member
iTrader: (17)
 
Join Date: Sep 2008
Location: Rogers, MN
Posts: 3,304
plot thickens
Stormzusmc is offline   Reply With Quote
Old 03-10-2011, 11:45 AM   #8  
Senior Member
iTrader: (22)
 
Join Date: Oct 2007
Location: New Orleans,La.
Posts: 1,397
mista0406 is offline   Reply With Quote
Old 03-10-2011, 11:56 AM   #9  
Senior Member
iTrader: (2)
 
Join Date: Nov 2008
Location: Ottawa Ontario
Posts: 1,023
You're spraying though cats and you'd like them warrantied?
SteveB123 is offline   Reply With Quote
Old 03-10-2011, 08:07 PM   #10  
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: Houston,TX
Posts: 638
my car has never been sprayed on its been in the shop for 2 months

i bought 4k in parts and putting them all in together

i called racingline 5 days a row 10 times a day and no response

now when you guys get a feedback all of a sudden you man up to defend yourself lol ...

Stop making excuse

I bought a new motor AND 2 new trannies

my motor right now is fine i bought a second motor to build it || eagle rods / wiseco pistons / ported head / etc ... (second motor has more then 150k miles ... why would i buy that to replace my fresh engine lol ....)
i will be swapping motor every few weeks depending on my mood if i wanna race or turn it into a daily ... i can get the swap done fairly easily so its nothing for me

but my motor right now is gonna remain in the car until my other motor is done (6 month project) because my extra tranny is also going to level 10 for a rebuild

AS for the mounts

I do not have time to go through that BS of sending you these back (AT MY MAILING COST) and then waiting another 2-3 weeks for you guys to send me another pair ..

your not gonna cover the cost of my car being on that lift without a subframe ...

and its that shops ONLY lift ...

Its the FACT that you guys sent me mounts for probably a honda

out of the 4 ..3 are small and 1 is taller ?

what the heck kinda machine is that ?

and it took me from jan 12th to mid feb to just get this ?!?!

These cats are worthless and people buying them will find out themselves once they start using them

Take my advice if you want or not i don't care ... your the ones losing money buying these cats They are ceramic just like the sh!tty stock oem ones and they will mess up

Just my Opinion with pics to how it worked out for me

got $$$ laying around go for it ... try it out yourself ...



These guys are only available before purchase

after that your fked .. no one answers the phone or replies

alot of people always get their packages late

but im just posting what i have been through and what i've seen again





This is just how the product turned out for me so this is my feedback

wait till you mess up yours then post up yourselves crying ....

Last edited by taz394; 03-10-2011 at 08:16 PM.
taz394 is offline   Reply With Quote
Old 03-10-2011, 10:42 PM   #11  
TAZ
Supporting Maxima.org Member
iTrader: (20)
 
Join Date: Oct 2004
Location: vancouver, BC
Posts: 589
Feedback is feedback, we make some mistakes but we wouldn't be around for the last 6 years getting bigger every year if something wasn't going right, but sadly people rarely post the positives.

The only reason I know this thread exists is because the .org sends out automated emails when you mention "Racingline", and even then it was 24hours later before I responded, it's not like I came running. Our number is not listed on the website and only given out on request due to the fact that there are only 2.5 of us running things. Racingline is still very small and I am the only one who handles the emails, forums, shipping + some fabrication and assembly so I have little time to be near the phone. Valid excuse? maybe not, but it's what we have to work with right now

whether your car is fine or not, there is way to much soot on the cats to be "normal" your car is at the least running very rich, but since you went ahead and gutted them instead of allowing us to inspect them we'll never know the cause of their failure. To the ceramic claims, they are full metallic CAR SOUND cats and are warrantied for 5yrs/50,000miles, the part number is stamped right on the side of them so feel free to look up the specs. The OEM cats are actually really good and very efficient, their problem is not in their design but their location coupled with the OEM tune the stock VQ has and it nature to run very rich under certain conditions.

As for the mounts. the one you mentioned being "taller" is also skinnier on the raised portion right? it was a blem mount that I mistakenly packed, the good one is still here inside the test mount. I would appear that I in fact made you 6spd inserts, and I accept the error. As such I would not make you return them if you wanted to swap because it is verified that it was MY mistake. I'm a big boy and have no problem admitting I'm wrong.

As for the time it took to make them, there is a notice on the website stating that the mounts are made to order and will take a week to get them into production. We did get backed up for a bit there when our servers went down in early Feb and it was a scramble to figure out what was wrong during the 36 hours it was offline. That down time created a backlog, for which I can only say sorry and it's unfortunate that you happened to get a double whammy when it happened. If you would like a refund on the mounts I have no problem doing so, you still have not emailed me to let me know what type of remedy would be suitable for you.

Where ever this thread goes from here I feel I have responded to the complaint and taken responsibly where it was needed so I will likely not respond anymore to avoid this thread being cluttered with back and forth bickering. I would ask that you email me how you would like me to remedy the mount situation and we will take it from there
TAZ is offline   Reply With Quote
Old 03-11-2011, 10:00 AM   #12  
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: Houston,TX
Posts: 638
i have nothing more to say ... im not trying to go out of my way and ruin anything for you guys and make sure you don't get any buisness

if it looks like that ..then sorry it was out of rage


the only thing i have left to say is it would be nice if you guys compensated me some of my money back from the amount i paid for these mounts because im paying $100 to get rings built/welded onto these mounts to make them fit ...

I STILL maybe plan on getting those traction rods from you guys cause thats pretty much the only thing i have not bought from you guys yet

that is all ...
taz394 is offline   Reply With Quote
Old 03-11-2011, 10:47 AM   #13  
TAZ
Supporting Maxima.org Member
iTrader: (20)
 
Join Date: Oct 2004
Location: vancouver, BC
Posts: 589
no worries, I''m glad to see this thread has gone somewhere constructive.

I will process a refund for the entire mount order & the grounding kit that was on the same order as a good will gesture. ($155 total)

There is no need to weld though, if you have access to a slip roller just get 1 piece of 12.5" long * 2.75" wide * .125" thick sheet and another @ 11.75" long and have them rolled. You can at that point just slide them into the mount and use the existing inserts, no welding required.

Or even easier just go to a local metal retailer and get some steel or aluminum tube @4" *0.25" wall tubing and cut it on a saw to 2.75" wide. The retailer will usually make the cut for you at no charge and again no welding will be required as the inserts are designed to be a pressure fit and will hold the ring in place. The ring method will cost you about $10 or less in parts

Last edited by TAZ; 03-11-2011 at 10:50 AM.
TAZ is offline   Reply With Quote
Old 03-11-2011, 02:48 PM   #14  
Senior Member
iTrader: (17)
 
Join Date: Jan 2007
Location: zimbabwe
Posts: 2,027
i wouldve just went with cattman headers over high flow cats in the first place ................ good luck 2 both parties
datdude20 is offline   Reply With Quote
Old 03-12-2011, 11:14 AM   #15  
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: Houston,TX
Posts: 638
Quote:
Originally Posted by Racingline View Post
no worries, I''m glad to see this thread has gone somewhere constructive.

I will process a refund for the entire mount order & the grounding kit that was on the same order as a good will gesture. ($155 total)

There is no need to weld though, if you have access to a slip roller just get 1 piece of 12.5" long * 2.75" wide * .125" thick sheet and another @ 11.75" long and have them rolled. You can at that point just slide them into the mount and use the existing inserts, no welding required.

Or even easier just go to a local metal retailer and get some steel or aluminum tube @4" *0.25" wall tubing and cut it on a saw to 2.75" wide. The retailer will usually make the cut for you at no charge and again no welding will be required as the inserts are designed to be a pressure fit and will hold the ring in place. The ring method will cost you about $10 or less in parts
thanks ...i'll try that out
taz394 is offline   Reply With Quote
Old 09-29-2015, 03:14 PM   #16  
Newbie - Just Registered
 
Join Date: Sep 2015
Posts: 4
Sorry to dig up an old topic but I placed an order and paid in full with RACINGLINE PERFORMANCE on 8/17/2015 and my order was processed on 8/18/2015 and still nothing. The order was for a Lower Torque Mount for a 2008 Nissan Sentra Spec V. After 5 or so emails to RACINGLINE via their websites "Contact Us" link i received a reply. It was as follows: "
I am very sorry for the delay. Your order should be leaving tomorrow. As soon as it leaves I will refund you your shipping costs for the delay. Thanks, Joe www.RacinglinePerformance.com On 9/14/2015 12:50 PM,"

That was over 2 weeks ago! I Just want my LTM, i don't understand what the hold up is? Even if it's a 1 man show, 2 months? Seriously?
Just hoping for a response from them. I can't get through on the phone or email any longer.
401Spec.V is offline   Reply With Quote
Old 10-05-2015, 11:44 AM   #17  
Newbie - Just Registered
 
Join Date: Sep 2015
Posts: 4
Sill no word from Racingline. Worst business I've dealt with, Ever. The lack of communication is Guinness World Record setting.
401Spec.V is offline   Reply With Quote
Old 10-22-2015, 12:39 PM   #18  
Newbie - Just Registered
 
Join Date: Sep 2015
Posts: 4
Still nothing. At All.
401Spec.V is offline   Reply With Quote
Old 10-29-2015, 04:30 PM   #19  
Newbie - Just Registered
 
Join Date: Sep 2015
Posts: 4
1 month from my post, still nothing
401Spec.V is offline   Reply With Quote
Old 12-25-2015, 10:27 PM   #20  
Newbie - Just Registered
 
Join Date: Dec 2015
Posts: 1
Wow!

This is the 1st site I went to , to look at aftermarket parts.

I'm glad I read this.

Any suggestions on where to find parts now?

Thank you
Max502 is offline   Reply With Quote
Old 09-26-2016, 09:25 AM   #21  
Newbie - Just Registered
 
Join Date: Jul 2013
Posts: 1
I made the mistake of ordering from them in early August. If anyone knows another contact at RP please let me know. I dropped some serious cash (for me) on precats and am starting to really worry.
kconan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad transmission bearing? HOKUSMAX 7th Generation Maxima (2009-2015) 4 11-13-2017 04:34 AM
The story of my beloved Maxima - Long Read hez8813 5th Generation Maxima (2000-2003) 10 02-06-2017 05:33 PM
hose issues. conansriver 5th Generation Maxima (2000-2003) 2 11-18-2015 02:46 PM
Plastdip the rims adamgalazka 8th Generation Maxima (2016-) 4 09-08-2015 01:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 04:22 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.