General Maxima Discussion This a general area for Maxima discussions for all years. For more specific questions, visit one of the generation-specific forums.

Air condition

Old 06-08-2019, 04:45 AM
  #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Jun 2019
Posts: 6
Air condition

Ok, I have a 2010 maxima that I had the compressor everything replaced and charged. My problem now is sometimes I can ride for 15 minutes before the cold air starts blowing. Especially if the car has sat for hours. When you turn it off you hear like a bubbly sound, like water going down a drain. Any ideas as to what I need to point my finger at to have looked at? Thanks in advance for all helpful advice
Karen Guy is offline  
Old 06-12-2019, 11:21 AM
  #2  
Ad·min·is·tra·tor
iTrader: (14)
 
DanNY's Avatar
 
Join Date: Aug 2000
Posts: 17,078
low on refrigerant?
DanNY is offline  
Old 06-12-2019, 12:45 PM
  #3  
Senior Member
 
Join Date: Apr 2009
Posts: 1,977
Expansion valve...that's my guess.
MadMax07SL is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
poolstick01
General Maxima Discussion
0
04-18-2002 07:42 PM
poolstick01
4th Generation Maxima (1995-1999)
3
02-19-2002 08:17 PM
MaxDriver98
General Maxima Discussion
2
12-29-2001 02:01 AM
MaxTod
General Maxima Discussion
0
07-24-2001 06:01 PM
MaxPower13
3rd Generation Maxima (1989-1994)
4
05-12-2001 05:54 PM


Thread Tools
Search this Thread
Quick Reply: Air condition


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.