5th Generation Maxima (2000-2003) Learn more about the 5th Generation Maxima, including the VQ30DE-K and VQ35DE engines.

Turn signals not working

Old 12-31-2018, 10:25 AM
  #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Turn signals not working

I have a 2000 Nissan Maxima SE with the turnsignals not working.

Diagnosing the problem I have replaced fuses for turn signals in the fuse box and replaced the turn signal relay module under the steering column. No luck neither of those worked. I have seen videos on YouTube checking the wires attached to the front headlight attached to the turn signal which will be my next step to look at. Anyone here seen this issue have any ideas?
Maximo1974 is offline  
Old 12-31-2018, 10:46 AM
  #2  
Junior Member
 
Join Date: Nov 2009
Location: NY
Posts: 70
make sure the wiring harness for your hazard switch is plugged in, the wiring circuit for the turn signal and relay goes through the hazard switch
fd3rew is offline  
Old 12-31-2018, 11:06 AM
  #3  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Where do I find the hazard switch harness located is it under the steering wheel near the turn signal relay fuse?
Maximo1974 is offline  
Old 12-31-2018, 11:19 AM
  #4  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
One thing I have done recently was replaced headlights on both sides but after I checked and made sure headlights and turn signals worked properly. I did notice how old and worn the wires are connecting to the headlights and turn signals.
Maximo1974 is offline  
Old 12-31-2018, 11:20 AM
  #5  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
One other thing I will try will be to replace the turn signal bulbs on both sides and look at these wires again to check any exposure of wire.
Maximo1974 is offline  
Old 12-31-2018, 02:26 PM
  #6  
Member
 
Join Date: Feb 2016
Location: Buffalo
Posts: 216
Originally Posted by Maximo1974 View Post
Where do I find the hazard switch harness located is it under the steering wheel near the turn signal relay fuse?
It's attached the hazard switch. Next to the change holder.
Theslaking is offline  
Old 12-31-2018, 03:09 PM
  #7  
Bad *** Newb
iTrader: (7)
 
Child_uv_KoRn's Avatar
 
Join Date: Jun 2006
Posts: 4,396
What about the actual switch? LOL
Child_uv_KoRn is offline  
Old 12-31-2018, 06:15 PM
  #8  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Yes I was hoping this is my last part to replace but I'll post the results soon.
Maximo1974 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Max4Speed
4th Generation Maxima (1995-1999)
9
02-05-2011 07:29 PM
96blackmaxSE
4th Generation Classifieds (1995-1999)
25
05-31-2009 05:17 PM
alexrovner
5th Generation Maxima (2000-2003)
4
02-29-2008 04:05 PM
99MAXSE-L
General Maxima Discussion
5
12-16-2003 06:24 PM


Thread Tools
Search this Thread
Quick Reply: Turn signals not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.