Transmission acts like it's in 5th gear consistently - Maxima Forums

Go Back  Maxima Forums > Maxima Discussions > 6th Generation Maxima (2004-2008)
Reload this Page >

Transmission acts like it's in 5th gear consistently

6th Generation Maxima (2004-2008) Discussion of the 6th generation Maxima. Come see what others are saying.

Transmission acts like it's in 5th gear consistently

Reply

 
 
 
Old 09-14-2018, 11:18 PM
  #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Sep 2018
Posts: 2
Transmission acts like it's in 5th gear consistently

I did a motor swap on my 04 Maxima now the gauge cluster and lights don't work and when you drive it it acts like it's in 5th gear consistently
Jeremy Weitzeil is offline  
Reply With Quote
Old 09-22-2018, 11:58 PM
  #2  
Newbie - Just Registered
 
Join Date: Sep 2018
Location: Miami , Florida
Posts: 1
Check the camshaft sensor the one on the front of the engine if it has oil all over it replace it and clean the connector if it has any oil in it. Should fix your problem at least it did for mine
Thexweeknd_ is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
95GreekMaxSE
4th Generation Maxima (1995-1999)
27
03-18-2004 02:49 PM
carma42
4th Generation Maxima (1995-1999)
9
11-02-2003 05:48 PM
hokiemax
General Maxima Discussion
8
06-18-2003 12:23 PM
ericdwong
General Maxima Discussion
5
06-11-2002 06:45 AM
whiteymax
4th Generation Maxima (1995-1999)
2
09-09-2001 02:19 PM


Thread Tools
Search this Thread
Quick Reply: Transmission acts like it's in 5th gear consistently


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.