2007 6AT surging issue - Maxima Forums

6th Generation Maxima (2004-2008) Discussion of the 6th generation Maxima. Come see what others are saying.

2007 6AT surging issue

Old 02-18-2019, 12:57 PM
  #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Feb 2019
Posts: 2
2007 6AT surging issue

So my 2007 Maxima just recently started doing a bit of a surge at highest speeds. I'll be cruising along, and briefly lose power, the rpms go up a bit, then it straightens out, almost like it's searching for a gear. Any ideas what the issue may be? Car has almost 140k.
Chad Sunderland is offline  
Old 02-19-2019, 03:23 AM
  #2  
Newbie - Just Registered
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Originally Posted by User1 View Post
Any codes? Fluid at the proper volume? Is it coming out of lock?
No codes, and the fluid is at the proper level. It MAY be coming out of lock. I'll be driving along at highway speed, and it suddenly feels disconnected, the rpms shoot up a bit, and then it goes back to normal. Does this sound like a lock issue? The issue first appeared 2 days ago, and is getting more frequent.
Chad Sunderland is offline  
Old 02-20-2019, 04:46 AM
  #3  
Senior Member
 
Join Date: Apr 2009
Posts: 1,898
2007 doesn't have an overdrive, it's CVT...I'm assuming that's what you mean when you as asking about coming out of Lock. CVT is a whole other animal...not an overdrive
MadMax07SL is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tnvmax
5th Generation Maxima (2000-2003)
4
12-18-2016 12:08 PM


Thread Tools
Search this Thread
Quick Reply: 2007 6AT surging issue


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.