7th Generation Maxima (2009-2015) Come in and talk about the 7th generation Maxima

Help please. Losing power while driving

Old 01-30-2019, 01:28 AM
  #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Aug 2018
Posts: 4
Help please. Losing power while driving

Help needed. While driving my 2012 Maxima will lose power, no warning lights. I pull over put into park then reverse then it stars running again. Any ideas as to what might be happening?
Jack85 is offline  
Old 01-30-2019, 05:11 AM
  #2  
Senior Member
 
Join Date: Feb 2009
Location: Central Florida
Posts: 1,048
Losing power is a rather broad description. Is the engine running or does it quit? Is it that the engine is running, but pushing on the accelerator doesn't cause the car to go faster? I am thinking that perhaps your cvt is overheating (either because of low levels, clogged radiator, or just contamination. Your cvt fluid should be a light green. If not, then it is time for the filter to be changed and a drain and fill. Remember to check the levels with the transmission thoroughly warmed up and on level ground. Let us know.
LtLeary is offline  
Old 01-30-2019, 10:34 AM
  #3  
Senior Member
iTrader: (2)
 
Join Date: Oct 2006
Location: Beantown
Posts: 2,135
I'm going to assume the entire car loses power not just the engine or transmission. In that case check that your battery terminals are not corroded.
Nopike is offline  
Old 01-30-2019, 10:25 PM
  #4  
Senior Member
 
Join Date: Mar 2009
Location: Maryland
Posts: 1,005
Great way to rule out transmission overheating is to invest in an OBDII dongle and an app that can read CVT temperature, great app is CVTz50 from Google play if you're on android. App is $4.99. Well worth the price.
mahanddeem is offline  
Old 02-13-2019, 03:06 PM
  #5  
Newbie - Just Registered
Thread Starter
 
Join Date: Aug 2018
Posts: 4
Thank you for the replyís. It turned out to be the alternator.
Jack85 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Andre Griffin
5th Generation Maxima (2000-2003)
1
01-27-2019 09:40 PM
NotYou
5th Generation Maxima (2000-2003)
6
01-25-2019 06:12 AM
DVC787
New Member Introductions
0
01-20-2019 04:12 PM
Jordan Mayo
5th Generation Maxima (2000-2003)
6
01-16-2019 07:14 PM
Shrout1
4th Generation Maxima (1995-1999)
10
01-10-2019 07:34 AM


Thread Tools
Search this Thread
Quick Reply: Help please. Losing power while driving


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.