problem : my sunroof cover is stuck - Maxima Forums



General Maxima Discussion This a general area for Maxima discussions for all years. For more specific questions, visit one of the generation-specific forums.

problem : my sunroof cover is stuck

Reply
 
 
 
Thread Tools Search this Thread
Old 08-05-2002, 01:21 PM   #1
Senior Member
Thread Starter
iTrader: (12)
 
Join Date: Dec 2000
Posts: 6,002
problem : my sunroof cover is stuck

the part where you slide manually... its stuck. I think it popped off the track or something, but I don't know how to put it back on track It started getting harder & harder to open a couple weeks ago, but it was ok I had to use a lil force & the shade will open/close. But last week it got really stiff that I kept pushing with BOTH of my hands & I saw some metal peice from the side of the sunroof falling off now its kinda stuck... the shade, what can I do/how do you remove that part of the sunroof???
costcowholesale is offline   Reply With Quote
Old 08-05-2002, 01:32 PM   #2
Senior Member
 
Join Date: Aug 2000
Posts: 2,530
I hate that POS recycled cardboard POS nissan quality thing. You're best bet is to loose the headliner entirely to see what had gone wrong in there.
ericdwong is offline   Reply With Quote
Old 08-05-2002, 01:33 PM   #3
Senior Member
Thread Starter
iTrader: (12)
 
Join Date: Dec 2000
Posts: 6,002
Quote:
Originally posted by ericdwong
I hate that POS recycled cardboard POS nissan quality thing. You're best bet is to loose the headliner entirely to see what had gone wrong in there.
how do I do that?? thats what I'm thinking taking teh whole roof apart
costcowholesale is offline   Reply With Quote
Old 08-05-2002, 01:51 PM   #4
Senior Member
 
Join Date: Jan 2002
Posts: 8,661
just leave it as is (if its not leaking and stuff) and just dont open it anymore. if you cant w/o having the roof open, then i guess it would be best to take it to the dealer......when it comes to things like the sun roof, its best not to DIY.
95emeraldgxe is offline   Reply With Quote
Old 08-05-2002, 02:01 PM   #5
Senior Member
Thread Starter
iTrader: (12)
 
Join Date: Dec 2000
Posts: 6,002
ok I forced the shade somemore & a peice of blast plastic fell off, now it moves a lil.... not very smooth but it moves.. I checked the rail/track on teh shade & it seems fine, its on the track but its just not sliding smoothly whats cauing this?
costcowholesale is offline   Reply With Quote
Old 08-05-2002, 02:11 PM   #6
Senior Member
 
Join Date: Jan 2002
Posts: 8,661
Quote:
Originally posted by costcowholesale
ok I forced the shade somemore & a peice of blast plastic fell off, now it moves a lil.... not very smooth but it moves.. I checked the rail/track on teh shade & it seems fine, its on the track but its just not sliding smoothly whats cauing this?
its cause that black piece isnt there anymore
95emeraldgxe is offline   Reply With Quote
Old 08-05-2002, 02:14 PM   #7
Senior Member
Thread Starter
iTrader: (12)
 
Join Date: Dec 2000
Posts: 6,002
Quote:
Originally posted by 95emeraldgxe


its cause that black piece isnt there anymore
what did I just break??
costcowholesale is offline   Reply With Quote
Old 08-05-2002, 03:42 PM   #8
MUSCLE Biotch!!!
iTrader: (3)
 
deezo's Avatar
 
Join Date: Apr 2001
Location: FV, NC
Posts: 14,275
I'm not finished with the sunroof repair writeup yet (busy with work and training) but look in the 4th gen faq. I did post a thread in there.


95emeraldgxe: We're here to help fix and modify Maximas, not just tell people leave it as is when it can be fixed.
deezo is offline   Reply With Quote
Old 08-05-2002, 05:16 PM   #9
Senior Member
 
Join Date: Aug 2000
Posts: 983
hey

its best to leave it alone i agree w/ the other guy.

i had the same problem on my 95, i went to ask for an estimate they said $1000 . Now i also had a slight leak which had already been repaired once.

What i had done was just pushed the visor all the way back and drove w/ it open this way i could still use my sunroof..

Another problem i had was when it came off the track and when i went over some bumps it would rattle, a quick fixfor that was just put some tape way back there.

sorry to give u the bad news...
tunedup is offline   Reply With Quote
Old 08-05-2002, 06:27 PM   #10
Member
 
Join Date: Jun 2001
Posts: 55
Funny I just saw this. I went to the nissan dealer today and just dropped $550 on a new slider... I was in tears handing him my credit card... Nissan refuses to carry the friggen metal clips that tend to lose their lubrication and break off...

So that was 550 there... 90 for a new jack which I waffled under my car... 20 bucks for new climate control bulbs..

After tax... $688...
SnOwBoaRdRXX is offline   Reply With Quote
Old 08-05-2002, 06:33 PM   #11
MUSCLE Biotch!!!
iTrader: (3)
 
deezo's Avatar
 
Join Date: Apr 2001
Location: FV, NC
Posts: 14,275
Quote:
Originally posted by SnOwBoaRdRXX
Funny I just saw this. I went to the nissan dealer today and just dropped $550 on a new slider... I was in tears handing him my credit card... Nissan refuses to carry the friggen metal clips that tend to lose their lubrication and break off...

So that was 550 there... 90 for a new jack which I waffled under my car... 20 bucks for new climate control bulbs..

After tax... $688...
You just got ripped off. I fixed my cousin's sunroof for $43.

How do I disassemble / rebuild my sticky sunroof?
Sunroof surgery...

http://forums.maxima.org/showthread.php?threadid=132724

Credit: Deezo


Costco, do the job yourself. If you have more questions, take pics and email me with questions.
deezo is offline   Reply With Quote
Old 08-05-2002, 07:16 PM   #12
Member
 
Join Date: Jun 2001
Posts: 55
Well what I forgot to mention was that I blew the fat guy and he gave it to me for free..

JK
SnOwBoaRdRXX is offline   Reply With Quote
Old 08-05-2002, 07:37 PM   #13
Senior Member
Thread Starter
iTrader: (12)
 
Join Date: Dec 2000
Posts: 6,002
Quote:
Originally posted by SnOwBoaRdRXX
Well what I forgot to mention was that I blew the fat guy and he gave it to me for free..

JK
snowboard: I think I broke the metal clip now its ok & sprayed shiet load of wd40 & gonna put greese on tomorrow... Did your sunroof visor get jammed too? Did you keep pushign it?? or is it stuck

Deezo, if it gets stuck again I'll try & take the whole roof apart & will email you if I have any questions.
costcowholesale is offline   Reply With Quote
Old 08-05-2002, 08:02 PM   #14
Member
 
Join Date: Jun 2001
Posts: 55
At first I broke one clip. The sunroof visor moved.. but I was careful with it cause losing 1 isn't that bad... but a few months later I broke another (due to 1 ******** friend smashing the visor closed), now causing it to pop off the track nonstop...

Basically you have 2 Clips (1 on each side) running along a rail, and when they lose lubrication they stub and snap. Losing 1 isn't really that bad, if you're gentle, because the other side should keep your sunroof in a straight enough alignment that it shouldn't start popping off.. (If I'm wrong, I'm sorry, this is just what I observed when messing around with my sunroof.)

||
||\\
|| \\
|| \\
|| \\
|| \\
|| ||
|| //
|| //
|| // ^
||// Clip
||

^
Rail

If people want to avoid this I'd get some lubricant in there from time to time, to make sure it slides with ease..
SnOwBoaRdRXX is offline   Reply With Quote
Old 08-05-2002, 08:06 PM   #15
Senior Member
Thread Starter
iTrader: (12)
 
Join Date: Dec 2000
Posts: 6,002
Quote:
Originally posted by SnOwBoaRdRXX
At first I broke one clip. The sunroof visor moved.. but I was careful with it cause losing 1 isn't that bad... but a few months later I broke another (due to 1 ******** friend smashing the visor closed), now causing it to pop off the track nonstop...

Basically you have 2 Clips (1 on each side) running along a rail, and when they lose lubrication they stub and snap. Losing 1 isn't really that bad, if you're gentle, because the other side should keep your sunroof in a straight enough alignment that it shouldn't start popping off.. (If I'm wrong, I'm sorry, this is just what I observed when messing around with my sunroof.)

||
||\\
|| \\
|| \\
|| \\
|| \\
|| ||
|| //
|| //
|| // ^
||// Clip
||

^
Rail

If people want to avoid this I'd get some lubricant in there from time to time, to make sure it slides with ease..
I checked, I didn't break the clips on the visor, I broke those black clips thats attached to the track
costcowholesale is offline   Reply With Quote
Old 02-17-2017, 12:40 AM   #16
Newbie - Just Registered
 
Join Date: Feb 2017
Posts: 1
Anyone ever figure out how to reinstall got new clips from yard but for the life of me can't reinstall Properly! Someone help please lol
Adi Sarkanjac is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Sunroof Problems Vequity 4th Generation Maxima (1995-1999) 7 09-10-2015 06:26 AM
Passenger headlight goes out after a a few moments. Maxima30 5th Generation Maxima (2000-2003) 2 09-07-2015 07:13 PM
Tranny safe mode / Grounding issue / cable replacement pktaske 6th Generation Maxima (2004-2008) 0 09-04-2015 09:40 AM
2001 max se sunroof problem mikebla General Maxima Discussion 0 09-03-2015 06:37 PM
Replacement CV Axle doesn't have cap that covers seal. Is this OK? (pics included) boomerbrian 5th Generation Maxima (2000-2003) 3 09-02-2015 04:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:54 AM.