Infiniti I30/I35 Similar to a Maxima, yet not really a Maxima. Discussion forum on Nissan's luxury model, the Infiniti I30/I35

Brake and Battery light

Old 07-05-2019, 03:23 PM
  #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Brake and Battery light

Hi, My 2003 I35 had both of these lights on then when I let the car rest a bit they were off?
Woody91557 is offline  
Old 07-05-2019, 04:16 PM
  #2  
I'm nutty for Nissans
iTrader: (46)
 
JSutter's Avatar
 
Join Date: Feb 2003
Location: Portland, Maine
Posts: 9,439
The alternator is failing.
JSutter is offline  
Old 07-05-2019, 05:44 PM
  #3  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Wow really just had that put in like 10 months ago....??? This is actually the 2nd one first replacement had a bearing go within 2 months could something be eating these?

Last edited by Woody91557; 07-05-2019 at 05:53 PM. Reason: add
Woody91557 is offline  
Old 07-06-2019, 05:18 AM
  #4  
Senior Member
iTrader: (2)
 
Join Date: Dec 2000
Location: Tampa Bay
Posts: 2,037
Originally Posted by JSutter View Post
The alternator is failing.
+1 ... classic symptom.
Turbobink is offline  
Old 07-06-2019, 05:47 AM
  #5  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Made in China Alts? Seems to me they should last longer than that.
Woody91557 is offline  
Old 07-06-2019, 10:49 AM
  #6  
Senior Member
iTrader: (2)
 
Join Date: Dec 2000
Location: Tampa Bay
Posts: 2,037
Originally Posted by Woody91557 View Post
Made in China Alts? Seems to me they should last longer than that.
Test it ... test the whole charging system for that matter.
Turbobink is offline  
Old 07-06-2019, 12:07 PM
  #7  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Put a volt meter to it 14.5 running 12.5 when not. She drove it today and no light. I'm hoping it was an anomaly I guess wait and see.

Last edited by Woody91557; 07-06-2019 at 12:10 PM. Reason: add
Woody91557 is offline  
Old 07-06-2019, 12:59 PM
  #8  
Senior Member
iTrader: (2)
 
Join Date: Dec 2000
Location: Tampa Bay
Posts: 2,037
Originally Posted by Woody91557 View Post
Put a volt meter to it 14.5 running 12.5 when not. She drove it today and no light. I'm hoping it was an anomaly I guess wait and see.
With the car running, was that with the A/C and headlights on?
Turbobink is offline  
Old 07-06-2019, 01:10 PM
  #9  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
No, Need to put a load on it? I will try that thanks.
Woody91557 is offline  
Old 07-06-2019, 03:06 PM
  #10  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Just tried it still got a 14.5
Woody91557 is offline  
Old 07-07-2019, 04:34 AM
  #11  
Senior Member
iTrader: (2)
 
Join Date: Dec 2000
Location: Tampa Bay
Posts: 2,037
The last thing I’d do would be a voltage drop test across the charge cable.

If that tests good, I’d maybe agree your trouble lights were a fluke.
Turbobink is offline  
Old 07-08-2019, 12:04 AM
  #12  
Senior Member
iTrader: (2)
 
Join Date: Apr 2004
Location: Plano, TX
Posts: 10,423
Check that the belt is not cracked and/or worn and that it is tight. A belt that is not fully tight can slip when it gets wet but work OK when dry.
DennisMik is offline  
Old 07-08-2019, 04:42 AM
  #13  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
OK, The belt seems fine it was put on new along with the Alt. but I was thinking the same. Don't want it to be the alt. again!

Last edited by Woody91557; 07-08-2019 at 04:43 AM. Reason: add
Woody91557 is offline  
Old Yesterday, 04:49 PM
  #14  
Newbie - Just Registered
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Just a quick update still no light!!
Woody91557 is offline  
Old Today, 05:03 AM
  #15  
Newbie - Just Registered
 
Join Date: May 2019
Posts: 5
Same thing happened to me. I had my alternator replaced by a mechanic. It died in a year. I realized that it was a remanufactured alternator that he put in. The second time around, I found an alternator on amazon (new not remanufactured). That second one is now 3 years old and has over 30,000 on it. So if you have been using remanufactured alternators, you may want to look at new. I heard all kinds of problems with remanufactured alternators.
I35GEEK is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigakphilly
6th Generation Maxima (2004-2008)
1
12-06-2014 07:45 AM
kxmike
4th Generation Maxima (1995-1999)
8
02-23-2006 07:13 PM
ttn_32
4th Generation Maxima (1995-1999)
9
12-13-2004 04:18 PM
wgray
4th Generation Maxima (1995-1999)
7
11-07-2004 08:06 AM
stringss240
4th Generation Maxima (1995-1999)
1
07-27-2004 05:35 PM


Thread Tools
Search this Thread
Quick Reply: Brake and Battery light


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.