Inaccurate Navigation - Maxima Forums



7th Generation Maxima (2009-2015) Come in and talk about the 7th generation Maxima

Inaccurate Navigation

Reply
 
 
 
Thread Tools Search this Thread
Old 01-12-2018, 03:28 PM   #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Jan 2018
Posts: 2
Inaccurate Navigation

So Iíve had my 2012 Maxima for more than a year now and I recently began having problems with my navigation. It regularly gives me the wrong location. Usually off by a couple blocks. Sometimes it corrects itself right alway sometimes it takes longer.

I took it to the dealer and and they ran diagnostics didnít find any problems. I went through the advance settings and everything showed up green saying my navigation had no problems.

I also recently got a remote start/GPS tracker on my car. Itís called Compustart. Idk if that might be effecting the signal, but when I took it back to the place I got t from they said they couldnít do anything and it was my navigations fault.

Any help or info is appreciated. Thanks
Bilal is offline   Reply With Quote
Old 01-12-2018, 03:32 PM   #2  
Member
 
Join Date: Dec 2016
Posts: 129
you need to update it
blackmax14 is offline   Reply With Quote
Old 01-12-2018, 03:44 PM   #3  
Newbie - Just Registered
Thread Starter
 
Join Date: Jan 2018
Posts: 2
Quote:
Originally Posted by blackmax14 View Post
you need to update it
Thatís what I assumed but I want to make sure that will solve the problem before I did that.
Bilal is offline   Reply With Quote
Old 01-13-2018, 01:43 PM   #4  
Senior Member
iTrader: (4)
 
Join Date: Mar 2009
Location: Miami, FL
Posts: 766
If there is a hardware issue. It is really not worth fixing at the dealer when you compare aftermarket or even cell phone solutions.
zoemayne is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
gtech, very inaccurate! maximazation General Maxima Discussion 5 02-26-2005 12:53 AM
Inaccurate fuel gauge chimpigin 4th Generation Maxima (1995-1999) 8 04-19-2004 11:18 AM
Gas gauge inaccurate maximum3rdgen 3rd Generation Maxima (1989-1994) 9 11-03-2003 07:49 PM
Found quick fix for inaccurate ambient temp. sensor sascuderi 5th Generation Maxima (2000-2003) 2 06-27-2003 07:27 AM
Speedometer inaccurate and sometimes does not work. any ideas? norton2099 4th Generation Maxima (1995-1999) 2 08-07-2001 05:16 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 07:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.