4th Generation Maxima (1995-1999) Visit the 4th Generation forum to ask specific questions or find out more about the 4th Generation Maxima.

1997 Nissan Maxima problem

Old 03-15-2019, 01:57 PM
  #1  
Newbie - Just Registered
Thread Starter
 
Join Date: Mar 2019
Posts: 2
1997 Nissan Maxima problem

Im having an issue with my 1997 Nissan Maxima. Iíve been experience a lot of engine surging both idling and revving. It was very subtle a few months ago but it has gotten really bad. The engine will start surging (stuttering, losing power then gaining it back, etc.) and sometimes it will cut the whole engine off. Today I was driving and the engine cuts off. Usually itís no problem, I just pull over and start her back up. But this time the engine would cut off right as I put it in reverse. I was able to get it started after cutting off the a/c, I donít know if that was coincidental or not. I was thinking idle air control valve or spark plugs as I havenít changed them yet and have had the car for almost 30,000 miles and it has over 300,000. Any advice or recommendations would be appreciated.
Josh Mann is offline  
Old 03-15-2019, 02:12 PM
  #2  
Senior Member
iTrader: (2)
 
Join Date: Dec 2000
Location: Tampa Bay
Posts: 1,974
maf ...
Turbobink is offline  
Old 03-15-2019, 07:07 PM
  #3  
Senior Member
 
Join Date: Mar 2014
Location: Planet Houston
Posts: 494
If it doesnt improve after cleaning the MAF:

fuel pump. rent a guage and check the pressure.

Thats all unless the pump has been replaced before.

are you aware of what transpired in this vehiclesí 300k miles before you?
reallywildstuff is offline  
Old 03-15-2019, 08:02 PM
  #4  
JvG
Senior Member
 
Join Date: Oct 2012
Location: Portland, Oregon
Posts: 2,031
Question: Does this problem occur when you stomp on the gas to accelerate ?

Is it worse on a hill?

Does it occur when the gas tank is nearly empty?

I've experienced those symptoms. They went away after replacing the fuel filter.
JvG is offline  
Old 03-18-2019, 09:46 PM
  #5  
Newbie - Just Registered
Thread Starter
 
Join Date: Mar 2019
Posts: 2
I appreciate all the responses. I went ahead and tried cleaning the mass airflow sensor and did the throttle body while I was at it. When putting the intake back together I saw a big tear on on the intake hose connecting to the throttle body. So I had a huge vacuum leak. I put some electrical tape over it for now and will be replacing it soon. Car runs great again with the temp fix.
Josh Mann is offline  
Old 03-19-2019, 04:50 AM
  #6  
Senior Member
iTrader: (2)
 
Join Date: Dec 2000
Location: Tampa Bay
Posts: 1,974
Occam's Razor cuts once again ...
Turbobink is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
speed3000gt
4th Generation Maxima (1995-1999)
7
08-22-2008 11:58 AM
stas29
4th Generation Maxima (1995-1999)
11
12-17-2002 07:32 AM
SB97MAX
4th Generation Maxima (1995-1999)
28
04-15-2001 08:19 PM
Tboogie
4th Generation Maxima (1995-1999)
2
12-27-2000 09:14 PM


Thread Tools
Search this Thread
Quick Reply: 1997 Nissan Maxima problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.